+7 (812) 677-17-05

Топ самых интересных CVE за июнь 2024 года

#

Вся информация, представленная ниже, предназначена только для ознакомительных целей. Автор не несет ответственности за вред, который может быть причинен с помощью предоставленной им информации.

В этой подборке представлены самые интересные уязвимости за июнь 2024 года.
Подведем вместе итоги первого месяца лета, поехали!


🟣 Критическая уязвимость в PHP

▶ CVE-2024-4577

Об уязвимости:
В языке программирования PHP, установленном в ОС Windows, обнаружена уязвимость, возникающая из-за функции преобразования символов Best Fit. Запуск PHP в режиме CGI на платформе Windows и использование определенных языковых настроек позволяет создавать вредоносные запросы в обход исправления CVE-2012-1823.
Затронуты версии PHP с 8.3 по 8.3.8, с 8.2 по 8.2.20, с 8.1 по 8.1.29.

Опубликована проверка концепции, которая доступна по ссылке.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику, не прошедшему проверку подлинности, выполнять произвольный вредоносный PHP-код на устройствах с Windows.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 9.8 баллов.

Подробнее:
CVE-2024-4577

🟣 Доступ к устройству через драйвер Wi-Fi для Windows

▶ CVE-2024-30078

Об уязвимости:
В драйвере Wi-Fi для Windows обнаружена уязвимость, позволяющая получать доступ к устройствам при подключении к общедоступным сетям Wi-Fi. Затронуты все версии Windows.

Эксплуатация:
Уязвимость позволяет злоумышленнику, не прошедшему проверку подлинности, при условии нахождения в зоне действия сети Wi-Fi выполнять произвольный вредоносный код в системе.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 8.8 баллов.

Подробнее:
CVE-2024-30078

🟣 Обход аутентификации в Progress MOVEit Transfer и MOVEit Gateway

▶ CVE-2024-5806

Об уязвимости:
В решении для передачи файлов MOVEit Transfer обнаружена уязвимость обхода механизма аутентификации, возникающая в модуле SFTP MOVEit. Затронуты версии с 2023.0.0 до 2023.0.11, с 2023.1.0 до 2023.1.6, с 2024.0.0 до 2024.0.2.

Опубликована проверка концепции, которая доступна по ссылке.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику обойти механизм аутентификации в ограниченных сценариях.

Исправление:
Всем пользователям рекомендуется как можно скорее выполнить обновление до последней версии (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 9.1 балла.

Подробнее:
CVE-2024-5806

▶ CVE-2024-5805

Об уязвимости:
В прокси-сервере MOVEit Gateway для MOVEit Transfer обнаружена уязвимость обхода механизма аутентификации, возникающая в SFTP-модуле. Затронут MOVEit Gateway версии 2024.0.0.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику обходить механизм аутентификации.

Исправление:
Всем пользователям рекомендуется как можно скорее выполнить обновление до последней версии (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 9.1 балла.

Подробнее:
CVE-2024-5805

🟣 Обход аутентификации в маршрутизаторах ASUS

▶ CVE-2024-3080

Об уязвимости:
В маршрутизаторах ASUS обнаружена уязвимость обхода аутентификации.

Затронуты продукты:

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику, не прошедшему проверку подлинности, получить контроль над устройствами.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление прошивки маршрутизаторов до актуальной версии (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 9.8 баллов.

Подробнее:
CVE-2024-3080

🟣 XML-уязвимость в Adobe Commerce

▶ CVE-2024-34102

Об уязвимости:
В ПО для электронной коммерции Adobe Commerce обнаружена уязвимость XML External Entity (XXE) с названием «CosmicSting». Затронуты версии 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 и более ранние версии.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику, не прошедшему проверку подлинности, получить несанкционированный доступ к конфиденциальным файлам, в том числе к файлам, содержащим пароли, а при определенных условиях позволяет выполнить произвольный код в системе.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление ПО (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 9.8 баллов.

Подробнее:
CVE-2024-34102

🟣 Уязвимости в продуктах VMware

▶ CVE-2024-37079 и CVE-2024-37080

Об уязвимостях:
В vCenter Server для VMware версий 7.0 и 8.0 и VMware Cloud Foundation версий 4.x и 5.x обнаружены уязвимости переполнения кучи в реализации протокола DCE/RPC.

Эксплуатация:
Уязвимости позволяют удаленному злоумышленнику с сетевым доступом к vCenter Server и Cloud Foundation, отправив специально сформированный сетевой пакет, выполнять произвольный код.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление продуктов (подробнее).

Оценка уязвимостей по шкале CVSS 3.1 — 9.8 баллов.

Подробнее:
CVE-2024-37079
CVE-2024-37080

▶ CVE-2024-37081

Об уязвимости:
В vCenter Server для VMware версий 7.0 и 8.0 и VMware Cloud Foundation версий 4.x и 5.x обнаружена уязвимость, возникающая из-за некорректной конфигурации sudo в vCenter Server.

Эксплуатация:
Уязвимость позволяет локальному злоумышленнику, прошедшему проверку подлинности, при условии отсутствия привилегий администратора повысить свои привилегии в системе до root.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление продуктов (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 7.8 баллов.

Подробнее:
CVE-2024-37081

🟣 Многочисленные уязвимости в продуктах Apple

▶ CVE-2024-23282

Об уязвимости:
В продуктах Apple, использующих FaceTime, была выявлена уязвимость, которая позволяет инициировать вызовы FaceTime без авторизации пользователя. Уязвимость возникает при открытии вредоносного электронного письма.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику проводить атаки, приводящие к утечке данных пользователей с устройства через FaceTime.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление продуктов до следующих версий: macOS Sonoma до 14.5, watchOS до 10.5, iOS до 17.5 и iPadOS до 17.5, iOS до 16.7.8 и iPadOS до 16.7.8.

Подробнее:
CVE-2024-23282

▶ CVE-2024-27812

Об уязвимости:
В Apple Vision Pro была выявлена уязвимость, связанная с обработкой специально созданного веб-контента, которая заключается в вызове любого типа 3D-объектов, включая анимированные и звуковые, путем перенаправления целевого пользователя на вредоносный сайт.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику, не прошедшему проверку подлинности, вызвать отказ в обслуживании (DoS-атаку).

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление продукта до visionOS версии 1.2 (подробнее).

Подробнее:
CVE-2024-27812

▶ CVE-2024-27801

Об уязвимости:
В ОС tvOS, visionOS, iOS, iPadOS, watchOS и macOS Sonoma Apple была выявлена уязвимость, связанная с повышением привилегий в компоненте NSXPC. Затронуты все версии компонента, начиная с момента их выпуска десять лет назад.

Опубликована проверка концепции, которая доступна по ссылке.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику, не прошедшему проверку подлинности, повышать свои привилегии в системе.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление своих устройств до версий tvOS 17.5, visionOS 1.2, iOS 17.5 и iPadOS 17.5, watchOS 10.5, macOS Sonoma 14.5.

Подробнее:
CVE-2024-27801

🟣 Доступ к GitHub-токенам в IntelliJ IDEA

▶ CVE-2024-37051

Об уязвимости:
В интегрированной среде разработки IntelliJ IDEA для работы с GitHub обнаружена уязвимость, связанная с некорректной обработкой  pull request , что приводит к утечке GitHub-токенов через IDE в процессе обработки этих запросов. Затронуты все версии с 2023.1.

Эксплуатация:
Уязвимость позволяет удаленному злоумышленнику, не прошедшему проверку подлинности, получить токены доступа к учетным записям пользователей и репозиториям Github.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление IDE и отозвать токены GitHub (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 9.3 балла.

Подробнее:
CVE-2024-37051

🟣 Бэкдор в роутерах D-Link

▶ CVE-2024-6045

Об уязвимости:
В роутерах D-Link обнаружена уязвимость, связанная со скрытым встроенным тестовым бэкдором, позволяющим активировать Telnet-сервис и получить доступ к учетным данным администратора.

Эксплуатация:
Уязвимость позволяет злоумышленнику в локальной сети, не прошедшему проверку подлинности, получить административный доступ к устройствам.

Исправление:
Компания D-Link выпустила обновления прошивки, рекомендуется обновить устройства, если обновление не было установлено автоматически (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 8.8 баллов.

Подробнее:
CVE-2024-6045

🟣 Уязвимость в Python-пакете Js2Py

▶ CVE-2024-28397

Об уязвимости:
В Python-пакете Js2Py до версии 0.74 включительно обнаружена уязвимость, связанная с ошибкой в компоненте js2py.disable_pyimport() js2py , позволяющая обойти изоляцию песочницы и выполнять код в системе.

Опубликована проверка концепции, которая доступна по ссылке.

Эксплуатация:
Уязвимость позволяет злоумышленнику, не прошедшему проверку подлинности, выполнять произвольный код с помощью созданного вызова API.

Исправление:
Всем пользователям рекомендуется как можно скорее применить доступное исправление (подробнее).

Подробнее:
CVE-2024-28397

🟣 Обход аутентификации в Veeam Recovery Orchestrator

▶ CVE-2024-29855

Об уязвимости:
В ИТ-решении Veeam Recovery Orchestrator (VRO) версий 7.0.0.337 и 7.1.0.205 обнаружена уязвимость обхода аутентификации, связанная с некорректной генерацией токенов аутентификации, что позволяет сгенерировать действительные токены для произвольного пользователя и успешно войти в систему.

Опубликована проверка концепции, которая доступна по ссылке.

Эксплуатация:
Уязвимость позволяет злоумышленнику, не прошедшему проверку подлинности, получить доступ к веб-интерфейсу VRO с правами администратора.

Исправление:
Всем пользователям рекомендуется как можно скорее провести обновление продукта (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 9.0 баллов.

Подробнее:
CVE-2024-29855

🟣 Переполнение буфера в прошивке Phoenix SecureCore UEFI

▶ CVE-2024-0762

Об уязвимости:
В прошивках для материнских плат Phoenix SecureCore UEFI, используемых в процессорах Intel, обнаружена уязвимость переполнения буфера с названием «UEFIcanhazbufferoverflow», связанная с небезопасным использованием переменной TCG2_CONFIGURATION в конфигурации TPM (Trusted Platform Module).

Эксплуатация:
Уязвимость позволяет локальному злоумышленнику, прошедшему проверку подлинности, повысить свои права в системе и выполнять произвольный код с привилегиями UEFI-прошивки.

Исправление:
Всем пользователям рекомендуется как можно скорее обновить свои устройства до последней версии (подробнее).

Оценка уязвимости по шкале CVSS 3.1 — 7.5 баллов.

Подробнее:
CVE-2024-0762

03.07.2024 Блог
Читайте все свежие новости первыми. Подписывайтесь на нас в Telegram
Том Хантер Том Хантер Pentest Guru

Мистер Том Хантер, вдохновитель нашей компании по обеспечению кибербезопасности

Спасибо

Спасибо, что заполнили форму! Мы свяжемся с вами в ближайшее время по указанным контактным данным!

Обратный звонок

Заполните форму и наш специалист свяжется с вами в ближайшее время.

    Принимаю соглашение об использовании персональных данных